What naming convention should I use for a JSON RPC client API designed for multiple languages?

This is the documentation with the original RPC client API specification. The naming convention in the specification is camel case with the first letter in lower case.

Naming conventions might differ in subtle ways for different languages (camel case with vs. w/o capitalization of the first letter), but for some conventions like snake case (Python) or Swift’s Fluent Usage API changing the names in the original specification might increase the cognitive load when using the API for those already familiar with the specification.

When searching for different JSON RPC APIs on GitHub, some implementations seem to take advantage of reflection to intercept method calls and pass them to RPC request “as is” so method names for that language are the same as in the original spec. If reflection is not available the names are hardcoded and are mostly the same as the spec, changing only the capitalization of letters for some languages.

Some examples:

Not using Fluent Design in Swift

https://github.com/fanquake/CoreRPC/blob/master/Sources/CoreRPC/Blockchain.swift
https://github.com/brunophilipe/SwiftRPC/blob/master/SwiftRPC/SwiftRPC+Requests.swift

Not using snake case in Ruby

https://github.com/sinisterchipmunk/bitcoin-client/blob/master/lib/bitcoin-client/client.rb

Changing method names to camel case in C#

https://github.com/cryptean/bitcoinlib/blob/master/src/BitcoinLib/Services/RpcServices/RpcService/RpcService.cs

Go to Source
Author: rraallvv

Naming problem helperpluginservice

I am looking for some service or plugin which can help with naming problem. Something that check consistency or checks for a verb in method names. May be suggesting how to shorten the name (which is not trivial for non native speakers). I’ve heard of code summarization researches. I don’t know will it solve such problem or not, but if it is, it would be interesting to look at such solution.

Go to Source
Author: Yaroslav Kishchenko

Naming convention for a function which checks whether scroll required or not?

There is function which checks whether scroll required or not by doing some DOM height width calucation before enabling the scroll in the webpage.

I named the function as checkScrollNeeded. Is there a better name or any naming conventions to refer.

Go to Source
Author: Sivashanmugam Kannan