SystemD application without sound

I am trying to run a kiosk application thanks to some videos played in chromium launched by a systemd service. When I am launching manually the following script, I can hear the sound of the videos

#!/bin/bash
xset s noblank
xset s off
xset -dpms

unclutter -idle 0.5 -root &

LIBVA_DRIVER_NAME=i965 /usr/bin/chromium-browser --noerrdialogs --autoplay-policy=no-user-gesture-required --disable-accelerated-video-decode --start-fullscreen --kiosk --incognito --disable-translate --no-first-run --fast --fast-start --disable-infobars --disable-features=TranslateUI --disk-cache-dir=/dev/null  --password-store=basic http://127.0.0.1

Unfortunately, when the script is launched by my kiosk.service, there isn’t sound (I found some similar cases on the forum but none seems to fix my issue)

cat /lib/systemd/system/kiosk.service
[Unit]
Description=Chromium Kiosk
Wants=graphical.target
After=graphical.target

[Service]
User=user1
Group=user1
Environment=DISPLAY=:0
Environment=XAUTHORITY=/home/user1/.Xauthority
Type=simple
ExecStart=/bin/bash /home/user1/kiosk.sh
Restart=on-abort

[Install]
WantedBy=graphical.target

Status :

user1@user1-nuc:~$ sudo systemctl status kiosk.service 
● kiosk.service - Chromium Kiosk
     Loaded: loaded (/lib/systemd/system/kiosk.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-09-06 17:52:11 CEST; 10s ago
   Main PID: 2822 (bash)
      Tasks: 102 (limit: 4523)
     Memory: 424.4M
     CGroup: /system.slice/kiosk.service
             ├─2822 /bin/bash /home/user1/kiosk.sh
             ├─2840 unclutter -idle 0.5 -root
             ├─2841 /usr/lib/chromium-browser/chromium-browser --enable-pinch --noerrdialogs --autoplay-policy=no-user-gesture-required --disable-accelerated-video-decode --start-fullscreen --kiosk --incognito >
             ├─2849 /usr/lib/chromium-browser/chromium-browser --type=zygote --no-zygote-sandbox --noerrdialogs
             ├─2850 /usr/lib/chromium-browser/chromium-browser --type=zygote --noerrdialogs
             ├─2852 /usr/lib/chromium-browser/chromium-browser --type=zygote --noerrdialogs
             ├─2872 /usr/lib/chromium-browser/chromium-browser --type=gpu-process --field-trial-handle=12499335857368612092,12890752898176720314,131072 --disable-features=TranslateUI --noerrdialogs --gpu-prefer>
             ├─2874 /usr/lib/chromium-browser/chromium-browser --type=utility --field-trial-handle=12499335857368612092,12890752898176720314,131072 --disable-features=TranslateUI --lang=en-US --service-sandbox->
             ├─2899 /usr/lib/chromium-browser/chromium-browser --type=renderer --autoplay-policy=no-user-gesture-required --disable-accelerated-video-decode --disable-webrtc-apm-in-audio-service --field-trial-h>
             ├─2926 /usr/lib/chromium-browser/chromium-browser --type=renderer --autoplay-policy=no-user-gesture-required --disable-accelerated-video-decode --disable-webrtc-apm-in-audio-service --field-trial-h>
             ├─2969 /usr/lib/chromium-browser/chromium-browser --type=renderer --autoplay-policy=no-user-gesture-required --disable-accelerated-video-decode --disable-webrtc-apm-in-audio-service --field-trial-h>
             └─2983 /usr/lib/chromium-browser/chromium-browser --type=utility --field-trial-handle=12499335857368612092,12890752898176720314,131072 --disable-features=TranslateUI --lang=en-US --service-sandbox->

sept. 06 17:52:13 user1-nuc bash[2841]: [2841:2871:0906/175213.315275:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:13 user1-nuc bash[2841]: [2841:2871:0906/175213.315295:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:13 user1-nuc bash[2841]: [2841:2871:0906/175213.315317:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:13 user1-nuc bash[2841]: [2841:2871:0906/175213.315336:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:13 user1-nuc bash[2841]: [2841:2871:0906/175213.315370:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:19 user1-nuc bash[2841]: [2841:2871:0906/175219.534878:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:19 user1-nuc bash[2841]: [2841:2871:0906/175219.534969:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:19 user1-nuc bash[2841]: [2841:2871:0906/175219.535020:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:19 user1-nuc bash[2841]: [2841:2871:0906/175219.535098:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>
sept. 06 17:52:19 user1-nuc bash[2841]: [2841:2871:0906/175219.535135:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp>

Have you an idea about this ?

Go to Source
Author: Rom D

Systemd service not starting – ‘Failed at step EXEC spawning… Permission denied’

I’ve read other answers for similar issues (Failed at step EXEC spawning… Permission denied) and none seem to apply.

After I upgraded my bitcoin node to v0.20.0 it is no longer starting on boot nor manually with systemctl start bitcoind.service.

Journalctl output:-

$ journalctl -xe
...
Jul 12 15:58:22 $HOSTNAME systemd[572]: bitcoind.service: Failed to execute command: Permission denied
Jul 12 15:58:22 $HOSTNAME systemd[572]: bitcoind.service: Failed at step EXEC spawning /usr/bin/bitcoind: Permission denied
-- Subject: Process /usr/bin/bitcoind could not be executed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- The process /usr/bin/bitcoind could not be executed and failed.

I’m using the default init script (https://github.com/bitcoin/bitcoin/blob/master/contrib/init/bitcoind.service) softlinked from my home directory to /etc/systemd/system/.

The executable is softlinked from my home directory into /usr/local/bin, so previous answer I’ve linked above suggesting an SELinux issue could apply but I don’t believe it is enabled: (-bash: getenforce: command not found). I am running Debian 10.4 and believe it is disabled by default.

$ ls -al /usr/bin/bitcoind 
lrwxrwxrwx 1 root root 34 May  5  2019 /usr/bin/bitcoind -> /home/$MY_NAME/src/bitcoin/src/bitcoind
$ ls -al /home/$MY_NAME/src/bitcoin/src/bitcoind
-rwxr-xr-x 1 bitcoin bitcoin 175058584 Jul  7 20:40 /home/$MY_NAME/src/bitcoin/src/bitcoind

Everything is set to run under the ‘bitcoin’ nologin user:

$ id bitcoin
uid=999(bitcoin) gid=999(bitcoin) groups=999(bitcoin)
$ cat /etc/passwd
...
bitcoin:x:999:999::/home/bitcoin:/bin/false
...

Here are the permissions on the relevant directories:

$ sudo ls -al /etc/bitcoin
total 12
drwx--x---  2 bitcoin bitcoin 4096 Jul 11 22:30 .
drwxr-xr-x 87 root    root    4096 Jul 12 15:58 ..
-rw-rw----  1 bitcoin bitcoin  601 Jul 11 22:30 bitcoin.conf
$ ls -al /var/lib/bitcoind
total 21896
drwx--x---  5 bitcoin bitcoin     4096 Jul  9 11:55 .
drwxr-xr-x 32 root    root        4096 Dec  5  2019 ..
...
$ ls -al /run
total 24
drwxr-xr-x 18 root        root         560 Jul 12 15:59 .
drwxr-xr-x 22 root        root        4096 Jun  2 17:46 ..
...

I’m stumped – any input greatly appreciated.

Go to Source
Author: Baron Mingus

Why does my Systemd command fail but I can execute it manually?

I can run the following command from my shell without issue

sudo -u ktrl /home/andrew/.cargo/bin/ktrl -d /dev/input/event3

However, when I try to make a service:

/etc/systemd/system/ktrl.service

[Unit]
Description=ktrl

[Service]
User=ktrl
Environment=HOME=/opt/ktrl
ExecStart=/home/andrew/.cargo/bin/ktrl -d /dev/input/event3
  
[Install]
WantedBy=multi-user.target

I get the following error from systemctl status ktrl.service

     Loaded: loaded (/etc/systemd/system/ktrl.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sat 2020-06-27 10:35:08 EDT; 5s ago
    Process: 23335 ExecStart=/home/andrew/.cargo/bin/ktrl -d /dev/input/event3 (code=exited, status=203/EXEC)
   Main PID: 23335 (code=exited, status=203/EXEC)
        CPU: 5ms

Jun 27 10:35:08 localhost.localdomain systemd[1]: Started ktrl.
Jun 27 10:35:08 localhost.localdomain systemd[23335]: ktrl.service: Failed to execute command: Permission denied
Jun 27 10:35:08 localhost.localdomain systemd[23335]: ktrl.service: Failed at step EXEC spawning /home/andrew/.cargo/bin/ktrl: Permission denied
Jun 27 10:35:08 localhost.localdomain systemd[1]: ktrl.service: Main process exited, code=exited, status=203/EXEC
Jun 27 10:35:08 localhost.localdomain systemd[1]: ktrl.service: Failed with result 'exit-code'.

I’m executing the command sudo -u ktrl /home/andrew/.cargo/bin/ktrl -d /dev/input/event3 as andrew. However, even if I switch to ktrl sudo su ktrl and run the command /home/andrew/.cargo/bin/ktrl -d /dev/input/event3 it still works

Go to Source
Author: user1991252

openvpn fails silently in systemd only

Brand new server.

I can start openvpn as a client at the cli using

openvpn --config /etc/openvpn/client.conf --verb 3

and pull a VPN ip address on the tun0 interface and ping the server just fine. But systemd fails silently without an error in any log.

service openvpn start

I did a standard

apt install openvpn

without any issues.

journalctl output:

Jun 11 06:19:12 fl.trader.com systemd[1]: Starting OpenVPN service...
Jun 11 06:19:12 fl.trader.com systemd[1]: Started OpenVPN service.

root@fl:/home/user# cat /etc/*-release

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian

root@fl:/home/user# openvpn –version

OpenVPN 2.4.7 arm-unknown-linux-gnueabihf [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Originally developed by James Yonan
Copyright (C) 2002-2018 OpenVPN Inc <sales@openvpn.net>
Compile time defines: enable_async_push=no enable_comp_stub=no enable_crypto=yes enable_crypto_ofb_cfb=yes enable_debug=yes enable_def_auth=yes enable_dependency_tracking=no enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_fast_install=needless enable_fragment=yes enable_iproute2=yes enable_libtool_lock=yes enable_lz4=yes enable_lzo=yes enable_maintainer_mode=no enable_management=yes enable_multihome=yes enable_pam_dlopen=no enable_pedantic=no enable_pf=yes enable_pkcs11=yes enable_plugin_auth_pam=yes enable_plugin_down_root=yes enable_plugins=yes enable_port_share=yes enable_selinux=no enable_server=yes enable_shared=yes enable_shared_with_static_runtimes=no enable_silent_rules=no enable_small=no enable_static=yes enable_strict=no enable_strict_options=no enable_systemd=yes enable_werror=no enable_win32_dll=yes enable_x509_alt_username=yes with_aix_soname=aix with_crypto_library=openssl with_gnu_ld=yes with_mem_check=no with_sysroot=no

root@flounder:/home/kermit# cat /etc/openvpn/client.conf

client
remote my-server-ip
dev tun
nobind
tls-client
ca /etc/openvpn/ca.crt
cert /etc/openvpn/trader.com.crt
key /etc/openvpn/trader.com.key
comp-lzo
verb 3
ping-restart 60

log /var/log/openvpn/openvpn.log

server:

root@vortex:/pki# cat /etc/openvpn/server.conf

mode server
tls-server
port 1194
proto udp
dev tun

ca      /pki/ca.crt
cert    /pki/issued/trader.com.crt
key     /pki/private/trader.com.key
dh      /pki/dh.pem

server 10.9.8.0 255.255.255.0
ifconfig-pool-persist ipp.txt
keepalive 10 120
comp-lzo         # Compression - must be turned on at both end
persist-key
persist-tun
status /var/log/openvpn-status.log
verb 4  # verbose mode
user nobody
group nogroup
client-config-dir /etc/openvpn/ccd
client-to-client
push "redirect-gateway bypass-dhcp"
push "route 192.168.0.0 255.255.255.0"
push "dhcp-option DNS 4.2.2.2"

log /var/log/openvpn/openvpn.log

How do I get openvpn to start in systemd?

Go to Source
Author: brad

Ubuntu 20.04 takes too long to boot

I have recently installed Ubuntu 20.04 on my HP-notebook(intel core i-5, 8GB RAM, AMD Radeon 2GB). It takes more than 2 min to reach the login screen.

I used the command dmesg to analyze which process it taking too much time only too see the below output:

If you go to timestamp [ 67.555730] rfkill: input handler disabled] , the process just after that by the name of audit has been called so many times and took nearly 50 secs of the boot process.

[   67.460851] [drm] ib test on ring 1 succeeded in 0 usecs
[   67.460874] [drm] ib test on ring 2 succeeded in 0 usecs
[   67.460899] [drm] ib test on ring 3 succeeded in 0 usecs
[   67.460924] [drm] ib test on ring 4 succeeded in 0 usecs
**[   67.555730] rfkill: input handler disabled**
[  111.331719] audit: type=1400 audit(1591675362.633:47): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/snap/snapd/7777/usr/lib/snapd/snap-confine" pid=1687 comm="apparmor_parser"
[  111.332012] audit: type=1400 audit(1591675362.633:48): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/snap/snapd/7777/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=1687 comm="apparmor_parser"
[  112.182135] audit: type=1400 audit(1591675363.485:49): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap-update-ns.snap-store" pid=1689 comm="apparmor_parser"
[  112.188690] audit: type=1400 audit(1591675363.493:50): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap-update-ns.canonical-livepatch" pid=1691 comm="apparmor_parser"
[  112.190389] audit: type=1400 audit(1591675363.493:51): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap.canonical-livepatch.hook.configure" pid=1694 comm="apparmor_parser"
[  112.192167] audit: type=1400 audit(1591675363.497:52): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap.canonical-livepatch.canonical-livepatch" pid=1692 comm="apparmor_parser"
[  112.192408] audit: type=1400 audit(1591675363.497:53): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap.canonical-livepatch.canonical-livepatchd" pid=1693 comm="apparmor_parser"
[  112.195750] audit: type=1400 audit(1591675363.497:54): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap-update-ns.vlc" pid=1698 comm="apparmor_parser"
[  112.196569] audit: type=1400 audit(1591675363.501:55): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap.snap-store.snap-store" pid=1695 comm="apparmor_parser"
[  112.197056] audit: type=1400 audit(1591675363.501:56): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap.snap-store.ubuntu-software" pid=1696 comm="apparmor_parser"
[  118.265070] kauditd_printk_skb: 2 callbacks suppressed
[  118.265076] audit: type=1400 audit(1591675369.569:59): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="/snap/core/9289/usr/lib/snapd/snap-confine" pid=1796 comm="apparmor_parser"
[  118.265095] audit: type=1400 audit(1591675369.569:60): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="/snap/core/9289/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=1796 comm="apparmor_parser"
[  118.797549] audit: type=1400 audit(1591675370.101:61): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/snap/snapd/7777/usr/lib/snapd/snap-confine" pid=1798 comm="apparmor_parser"
[  118.836034] audit: type=1400 audit(1591675370.141:62): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/snap/snapd/7777/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=1798 comm="apparmor_parser"
[  119.433628] audit: type=1400 audit(1591675370.737:63): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap-update-ns.core" pid=1800 comm="apparmor_parser"
[  119.529999] audit: type=1400 audit(1591675370.833:64): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.core.hook.configure" pid=1801 comm="apparmor_parser"
[  120.144506] audit: type=1400 audit(1591675371.449:65): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.snap-store" pid=1803 comm="apparmor_parser"
[  120.175883] audit: type=1400 audit(1591675371.481:66): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap-update-ns.vlc" pid=1806 comm="apparmor_parser"
[  120.190680] audit: type=1400 audit(1591675371.493:67): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.ubuntu-software" pid=1804 comm="apparmor_parser"
[  120.211819] audit: type=1400 audit(1591675371.517:68): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap-update-ns.canonical-livepatch" pid=1808 comm="apparmor_parser"
[  147.119565] kauditd_printk_skb: 6 callbacks suppressed
[  147.119569] audit: type=1400 audit(1591675398.426:75): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="/snap/snapd/7777/usr/lib/snapd/snap-confine" pid=1934 comm="apparmor_parser"
[  147.119577] audit: type=1400 audit(1591675398.426:76): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="/snap/snapd/7777/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=1934 comm="apparmor_parser"
[  147.918540] audit: type=1400 audit(1591675399.222:77): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.ubuntu-software" pid=1938 comm="apparmor_parser"
[  147.948852] audit: type=1400 audit(1591675399.254:78): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.ubuntu-software-local-file" pid=1939 comm="apparmor_parser"
[  148.020594] audit: type=1400 audit(1591675399.326:79): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.snap-store" pid=1937 comm="apparmor_parser"
[  148.216393] audit: type=1400 audit(1591675399.522:80): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap-update-ns.snap-store" pid=1936 comm="apparmor_parser"
[  210.116607] [drm] PCIE gen 3 link speeds already enabled
[  210.133629] [drm] PCIE GART of 2048M enabled (table at 0x0000000000040000).
[  210.133736] radeon 0000:01:00.0: WB enabled
[  210.133739] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0x0000000002c29bac
[  210.133740] radeon 0000:01:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0x00000000f44304ae
[  210.133742] radeon 0000:01:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0x0000000031bde5cd
[  210.133743] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0x00000000d7e92f5c
[  210.133744] radeon 0000:01:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0x000000001f77e5bc
[  210.326579] [drm] ring test on 0 succeeded in 1 usecs
[  210.326584] [drm] ring test on 1 succeeded in 1 usecs
[  210.326588] [drm] ring test on 2 succeeded in 1 usecs
[  210.326596] [drm] ring test on 3 succeeded in 4 usecs
[  210.326603] [drm] ring test on 4 succeeded in 4 usecs
[  210.326671] [drm] ib test on ring 0 succeeded in 0 usecs
[  210.326732] [drm] ib test on ring 1 succeeded in 0 usecs
[  210.326820] [drm] ib test on ring 2 succeeded in 0 usecs
[  210.326833] [drm] ib test on ring 3 succeeded in 0 usecs
[  210.326844] [drm] ib test on ring 4 succeeded in 0 usecs
[  210.334790] rfkill: input handler enabled
[  210.715243] Bluetooth: RFCOMM TTY layer initialized
[  210.715258] Bluetooth: RFCOMM socket layer initialized
[  210.715273] Bluetooth: RFCOMM ver 1.11
[  224.498251] audit: type=1400 audit(1591675475.797:81): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.ubuntu-software-local-file" pid=2256 comm="apparmor_parser"
[  224.529105] audit: type=1400 audit(1591675475.829:82): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.snap-store" pid=2254 comm="apparmor_parser"
[  224.546528] audit: type=1400 audit(1591675475.845:83): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.snap-store.ubuntu-software" pid=2255 comm="apparmor_parser"
[  224.820589] audit: type=1400 audit(1591675476.121:84): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap-update-ns.snap-store" pid=2253 comm="apparmor_parser"
[  233.396341] rfkill: input handler disabled
[  236.218843] [drm] PCIE gen 3 link speeds already enabled
[  236.230351] [drm] PCIE GART of 2048M enabled (table at 0x0000000000040000).
[  236.230455] radeon 0000:01:00.0: WB enabled
[  236.230458] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0x0000000002c29bac
[  236.230459] radeon 0000:01:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0x00000000f44304ae
[  236.230460] radeon 0000:01:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0x0000000031bde5cd
[  236.230461] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0x00000000d7e92f5c
[  236.230462] radeon 0000:01:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0x000000001f77e5bc
[  236.422306] [drm] ring test on 0 succeeded in 1 usecs
[  236.422311] [drm] ring test on 1 succeeded in 1 usecs
[  236.422315] [drm] ring test on 2 succeeded in 1 usecs
[  236.422323] [drm] ring test on 3 succeeded in 4 usecs
[  236.422329] [drm] ring test on 4 succeeded in 4 usecs
[  236.422393] [drm] ib test on ring 0 succeeded in 0 usecs
[  236.422422] [drm] ib test on ring 1 succeeded in 0 usecs
[  236.422554] [drm] ib test on ring 2 succeeded in 0 usecs
[  236.422583] [drm] ib test on ring 3 succeeded in 0 usecs
[  236.422597] [drm] ib test on ring 4 succeeded in 0 usecs

Also, it takes about 10 secs to load the desktop and icons from login screen.

Below is the head of the output of $system-analyze blame.

41.797s plymouth-quit-wait.service                           
25.586s man-db.service                                       
21.755s NetworkManager-wait-online.service                   
19.547s networkd-dispatcher.service                          
12.294s apt-daily.service                                    
10.432s dev-sda2.device                                      
10.193s udisks2.service                                      
 9.942s accounts-daemon.service                              
 7.864s NetworkManager.service                               
 7.050s snapd.service                                        

Go to Source
Author: Hades