A container having 2 or more elements could be called a “plural container”. A container with no elements could be called an “empty container”.
But what is the terminology for a container whose current size is exactly 1 element?
I would use the term “unary” but that refers to operators that take exactly 1 argument.
The reason I would like a term for this is that I am writing a boolean method to check if two data structures are both of size exactly one and I want a good name for the method. Currently I have:
def length_is_1(self, x, y):
return len(x) == 1 and len(y) == 1
Go to Source
Author: Terrence Brannon
After reading some articles about DevOps, I understand that DevOps engineers do write code. However, it’s a bit unclear to me about what kind of code a DevOps engineer write.
Assume that there are (very roughly) 2 categories of code:
- For system operation: like scripting for deployment, configuration of Puppet or Ansible, etc.
- For user requirement: e.g. allow user to upload avatar images, add an “export” button to download as .csv files.
I found that some DevOps engineers only do the first category, while some others do both.
My question: is it common for DevOps engineers to write code for user requirements?
Go to Source