E:Malformed entry 52 in list file /etc/apt/sources.list (Component), E:The list of sources could not be read [duplicate]

ok i get this message and don’t have the slightest idea how to change that list.tried it with an editor,thought i changed the mistake,but keep getting the same response although i edited it.So now i don’t know which sourcelist it uses cause there are a few.

Go to Source
Author: Enzo Ricotta

Can’t upgrade OS Install (MATE); How to solve, please?

I have seen similar issues but am not being able to quite solve the issue…

Probably easy I guess…

W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target CNF (main/cnf/Commands-i386) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target CNF (main/cnf/Commands-i386) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3
W: Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/vivaldi.list:3

Appreciate a lot!

Go to Source
Author: Risen

Why am I being asked to Restart System even though I have Canonical Livepatch?

I’m confused about when I need to do system restarts even though I have Canonical Livepatch on Ubunut 20.04LTS Server

$ sudo canonical-livepatch status --verbose
last check: 22 minutes ago
kernel: 5.4.0-29.33-generic
server check-in: succeeded
patch state: ✓ no livepatches needed for this kernel yet
client version: 9.5.5
architecture: x86_64
cpu model: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz
boot time: 3 weeks ago

Logging in gave me

Welcome to Ubuntu 20.04 LTS (GNU/Linux 5.4.0-29-generic x86_64)
62 updates can be installed immediately.
38 of these updates are security updates

So I did the usual

sudo apt update
sudo apt upgrade -y

but now I get
*** System restart required ***

and

$ cat /var/run/reboot-required.pkgs
linux-image-5.4.0-33-generic
linux-base

So do I need to restart and if so why? Isn’t Livepatch meant to take care of critical Kernel patches. Or am I misunderstanding what linux-image and linux-base are?

My understanding is that Livepatch exists so we don’t need to restart. How do I avoid this situation while still doing the security updates.

Go to Source
Author: Gazzer

load_plugin_textdomain was called with an argument that is deprecated since version 2.7.0 with no alternative available

I tried to update Avada theme using ftp. I deleted Avada folder and copied that again from zip file I downloaded. Since then, I am facing these errors:

    Deprecated: load_plugin_textdomain was called with an argument that is deprecated since version 2.7.0 with no alternative available. in /home/avang/domains/avang.ir/public_html/wp-includes/functions.php on line 5007

Deprecated: load_plugin_textdomain از نگارش 2.7.0 از رده خارج شده و هیچ جایگزینی برای آن وجود ندارد. in /home/avang/domains/avang.ir/public_html/wp-includes/functions.php on line 5007

Deprecated: has_cap از نگارش 2.0.0 از رده خارج شده! استفاده از رده‌های کاربر، منسوخ شده است. از قابلیت‌ها (capabilities) به جای آن استفاده نمایید. in /home/avang/domains/avang.ir/public_html/wp-includes/functions.php on line 4997

Deprecated: has_cap از نگارش 2.0.0 از رده خارج شده! استفاده از رده‌های کاربر، منسوخ شده است. از قابلیت‌ها (capabilities) به جای آن استفاده نمایید. in /home/avang/domains/avang.ir/public_html/wp-includes/functions.php on line 4997
Deprecated: contextual_help از نگارش3.3.0 منسوخ شده است! به‌جای آن از get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab() استفاده نمایید. in /home/avang/domains/avang.ir/public_html/wp-includes/functions.php on line 5088
    Notice: Undefined offset: 0 in /home/avang/domains/avang.ir/public_html/wp-content/plugins/wp-parsidate/includes/fixes-permalinks.php on line 246

Notice: Undefined offset: 1 in /home/avang/domains/avang.ir/public_html/wp-content/plugins/wp-parsidate/includes/fixes-permalinks.php on line 247

Notice: Undefined offset: 2 in /home/avang/domains/avang.ir/public_html/wp-content/plugins/wp-parsidate/includes/fixes-permalinks.php on line 248

could somebody help please?

Go to Source
Author: Arya

Trying to upgrade to a new release version, having trouble with /etc/apt/sources.list

Trying to upgrade to a new release version, having trouble with /etc/apt/sources.list

I am trying to upgrade to a new release version following the instructions of the accepted answer here.

Someone mentioned in the comments section of the OP’s question that you should change http://old-releases.ubuntu.com/ubuntu/ to http://us.archive.ubuntu.com/ubuntu/
so that’s what I did. The current state of my sources.list file is as shown below.

enter image description here
enter image description here

When I try to run sudo apt-get update && sudo apt-get dist-upgrade, I get

Ign:1 http://us.archive.ubuntu.com/ubuntu disco InRelease
Hit:2 http://packages.microsoft.com/repos/vscode stable InRelease                                                            
Ign:3 http://us.archive.ubuntu.com/ubuntu disco-updates InRelease                                                            
Hit:4 http://dl.google.com/linux/chrome/deb stable InRelease                              
Hit:5 https://repo.skype.com/deb stable InRelease                                         
Ign:6 http://us.archive.ubuntu.com/ubuntu disco-backports InRelease                       
Hit:7 http://ppa.launchpad.net/bit-team/stable/ubuntu disco InRelease
Ign:8 http://us.archive.ubuntu.com/ubuntu disco-security InRelease
Err:9 http://us.archive.ubuntu.com/ubuntu disco Release                            
  404  Not Found [IP: 91.189.91.39 80]
Err:10 http://us.archive.ubuntu.com/ubuntu disco-updates Release                   
  404  Not Found [IP: 91.189.91.39 80]
Err:11 http://us.archive.ubuntu.com/ubuntu disco-backports Release
  404  Not Found [IP: 91.189.91.39 80]
Err:12 http://us.archive.ubuntu.com/ubuntu disco-security Release
  404  Not Found [IP: 91.189.91.39 80]
Ign:13 http://ppa.launchpad.net/pmcenery/ppa/ubuntu disco InRelease
Err:14 http://ppa.launchpad.net/pmcenery/ppa/ubuntu disco Release
  404  Not Found [IP: 2001:67c:1560:8008::15 80]
Reading package lists... Done
E: The repository 'http://us.archive.ubuntu.com/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://us.archive.ubuntu.com/ubuntu disco-updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://us.archive.ubuntu.com/ubuntu disco-backports Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://us.archive.ubuntu.com/ubuntu disco-security Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/pmcenery/ppa/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

What should I do?

Go to Source
Author: An Ignorant Wanderer